Windows 10 not receiving mic audio

Jake7777

New Member
Jun 16, 2019
2
USA
OS
Windows 10
BR
Edge 18.17763
Hello, this is a common problem from what I've read so far. Summed up, Windows 10 detects my new headset's mic but is not receiving any audio input from it. When I speak or tap on the mic, no green bars appear in the sound menu as well as discord/windows voice recorder not detecting any input.

My rig:
Acer Predator, Windows 10 (Version 1809, build 17763.557)

My headset:
SteelSeries Arctis 5 (USB)

What I've tried so far:
I have tested my headset with my phone using a 3.5mm, and audio input/output worked normally. I also tested this with a different desktop running windows 10 and experienced the same problem.

1) Default microphone is set to Arctis 5 and enabled, all others are disabled
2) Audio enhancements are disabled
3) Volume is maxed in "levels" tab of microphone properties
3) Allow applications to take exclusive control is disabled
4) Fully updated windows
5) Reinstalled and attempted to update headset drivers (no updates)
6) Plugged in headset using every USB port
7) Ran audio troubleshooter, didn't help
8) Tried to configure mic, can't go past the part where windows asks you to speak into the mic because it doesn't detect any audio from it.
9) In Privacy, allowed all apps to access microphone
10) Downloaded steelseries' engine, program can't detect audio when trying a live mic test and it's pretty much useless for anything outside of tweaking sound settings
11) Connected headset using 3.5mm jack, both audio and microphone stopped working
12) And before anyone asks, yes I made sure the mic isn't muted by the headset itself

I have also looked for brand-specific drivers from steelseries but can't find any. I've tried everything I can think of and everything I've read online. Any help is appreciated, and if anyone wants additional information or screenshots just let me know.
 

DVDR_Dog

Well-Known Member
Donator
Nov 5, 2018
124
OS
Windows 10
BR
Chrome 75.0.3770.90
OK quick and stupid question. Have you tried to install this headset on different Win 10 system? I asked because it's a start on eliminating possibilities. Bear with me please.
 

Jake7777

New Member
Jun 16, 2019
2
USA
OS
iOS
BR
Mobile Safari 12.0
OK quick and stupid question. Have you tried to install this headset on different Win 10 system? I asked because it's a start on eliminating possibilities. Bear with me please.
Yes, I plugged the headset in on a desktop running windows 10 and ran into the exact same problem.
 

DVDR_Dog

Well-Known Member
Donator
Nov 5, 2018
124
OS
Windows 10
BR
Chrome 75.0.3770.90
Nothing you want to hear then Jake. It's gotta be a hardware problem. Anything USB is always suspect but only a few users have been able to make the headsets work mostly overcoming bad initial installs which leads me to believe QC must be poor at SteelSeries. If there's anyway to return them and get your money back run don't walk. There are way too many unsolved hardware problems with this brand spanning years regardless of how sites rate them. The sites probably get cherry picked good ones and who knows what else perks for good ratings. The large unsatisfied user base makes me think that's more of their true ratings. At worst RMA the darn things and I hope you get a good set next time.
If there was a true fix for these available you had better believe the manufacturer would post it and take steps to upgrade all owners away from any software problem that existed.
Sorry I can't be of any more help. If I am wrong please let me know. It won't be the first time.
 
  • Like
Reactions: ThumperTM

ThumperTM

El Patrón
Owner
Aug 18, 2010
11,763
New Zealand
OS
Windows 10
BR
Chrome 74.0.3729.169
Nothing you want to hear then Jake. It's gotta be a hardware problem. Anything USB is always suspect but only a few users have been able to make the headsets work mostly overcoming bad initial installs which leads me to believe QC must be poor at SteelSeries. If there's anyway to return them and get your money back run don't walk. There are way too many unsolved hardware problems with this brand spanning years regardless of how sites rate them. The sites probably get cherry picked good ones and who knows what else perks for good ratings. The large unsatisfied user base makes me think that's more of their true ratings. At worst RMA the darn things and I hope you get a good set next time.
If there was a true fix for these available you had better believe the manufacturer would post it and take steps to upgrade all owners away from any software problem that existed.
Sorry I can't be of any more help. If I am wrong please let me know. It won't be the first time.
I agree.